Flask-User v1.0

Customizable User Authentication, User Management, and more.

Attention

This is Flask-User v1.0 which is incompatible with Flask-User v0.6.
Flask-User v1.0 is basically Flask-User v0.6 with a more Pythonic API for customization.
This package is production grade, but it is marked as an alpha release because its API may be subject to change.
So, you’re writing a Flask web application and would like to authenticate your users.
You start with a simple Login page, but soon enough you’ll need to handle:
  • Registrations and Email Confirmations
  • Change Usernames, Change Passwords, and Forgotten Passwords

And wouldn’t it be nice to also offer:

  • Added Security
  • Increased Reliability
  • Role-based Authorization
  • Internationalization (Chinese, Dutch, English, Farsi, Finnish, French, German, Italian, Russian, Spanish, Swedish, and Turkish)

Customizable, yet Ready to use

  • Largely Configurable – By overriding configuration settings.
  • Fully Customizable – By overriding methods and properties.
  • Ready to use – Through sensible defaults.
  • Supports SQL and MongoDB databases.

Additional features

  • MIT License
  • Tested on Python 2.6, 2.7, 3.3, 3.4, 3.5 and 3.6. Coverage: Over 90%.
  • Event hooking – Through efficient signals.
  • Support for multiple emails per user

Minimal Requirements

  • brypt 2.0+
  • cryptography 1.6+
  • Flask 0.9+
  • Flask-Login 0.2+
  • Flask-WTF 0.9+
  • passlib 1.6+

Authors

Lead developer and Maintainer
Ling Thio – ling.thio AT gmail DOT com

Contributors